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1 Ruskin software
Ruskin is the only tool you need to manage all your RBR instruments and measurement data. It is available for Mac and 
Windows PC. 

Use the Ruskin software to do the following:
Configure, schedule, and enable multiple instruments
Estimate your deployment times
Download your data after logging
View your datasets graphically
Export your data in various formats
Analyse your data
Change the calibration coefficients for your instrument
Perform user calibration
Contact RBR

RSK files generated by Ruskin contain contain raw measurement data, firmware and software versions, dates and 
times, sampling settings, power settings, measured and derived parameters, errors and events, other diagnostic 
information. They can be read directly in Matlab, or exported to Excel, OceanDataView®, or text files. 

Find Ruskin software for Mac and PC on the USB stick included with your instrument, or visit the RBR website to 
download the latest version. 

The most recent software updates, release notes, Ruskin user guides, instrument guides, and quick start guides are 
available from the Help menu in Ruskin.

https://rbr-global.com/products/software/
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2 Ruskin interface
Ruskin software has a user-friendly interface which consists of a Toolbar and three main windows: Navigator, 
Properties, and Plot.

In the Navigator window, you will find the list of instruments connected to Ruskin, as well as MLM (if applicable) and 
datasets. 

When an instrument on the list is selected, the Properties window displays four tabs with information related to this 
instrument: Configuration, Information, Calibration, and Parameters. Use these tabs to configure your deployment, 
check the calibration certificates, and verify your parameters.

The data plot will appear in the Plot window below if the realtime option is available and selected for this instrument, or 
if you click the Fetch button    on the far right of the toolbar. 

Click-and-drag window tabs to rearrange the windows within Ruskin, or move a window outside of Ruskin. Hover over a 
side of a window, and when the cursor becomes a two-way arrow , move it to adjust the window size. 
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Click the Close  button in the top right corner to close a window. For example, you can close the Navigator
window to have a better view of the Properties. The closed window icon will appear on the sidebar (in this case, 

Navigator ). Click the Multiple windows  button above the closed window icon to re-open it. 

Double-click a window tab to maximise that window, and double-click the tab again to return it to the original size. 

Alternatively, use the Single window  and Multiple windows   buttons. 

When you restart Ruskin, it returns to its original layout. 



RBR#0006106revJ

 
8

 

The Toolbar at the top left above the Navigator window has four dropdown menus. If you are using a Mac computer, it 
appears as follows:

On a Windows PC, the Toolbar looks slightly differently:

The rest of the interface is the same between the two systems. 

.

.

2.1 Ruskin / Options
On your Mac, go to the Ruskin dropdown menu to access information on current software version, set up your 
preferences, or quit Ruskin. Note that the rest of the options on this dropdown menu depend on your operating system 
and are external to Ruskin. 

On your Windows PC, use the Options dropdown menu to set up your preferences. 
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2.2 File
Go to the File dropdown menu to open or close a dataset, export your data, and see the list of available datasets. The 
Datasets menu in the Navigator windows duplicates some of these options for convenience. 

2.3 Instruments
Go to the Instruments dropdown menu to simulate an instrument, update your firmware, set up automatic tasks, or 
take advantage of the utilities. 

The Instruments menu in the Navigator windows duplicates some of these options for convenience. 

2.4 Help
Go to the Help dropdown menu to access the latest release notes and technical documentation, provide your feedback, 
check for updates, or to add a beta feature. 

The Utilities option is a support tool. Do not use unless instructed by RBR. 
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3 Installation
Ruskin is the only piece of software you need to operate your RBR instruments. RBR releases Ruskin software versions 
compatible with Mac and PC (Ruskin Desktop), as well as with iOS® and Android™ (Ruskin Mobile). 

Install the Ruskin Mobile app on your mobile device by going to the Apple App store or Google Play. 

Follow the steps below to install Ruskin Desktop on your computer. 

3.1 Install Ruskin on a PC
You can install Ruskin on a PC that runs the Windows 7, 8, 8.1, or 10 operating system.

The minimum requirements for Ruskin are:
OS = Windows 7
Processor speed = 1.4GHz 
RAM required = 2GB 
Display resolution = 1024x768 recommended 
HDD space for installation = 500MB

The instruments use a USB interface to communicate with Ruskin.

Steps
Connect the USB stick included with your instrument to a port on your computer.
Navigate to the "Ruskin Installation" folder and doubleclick on the file RuskinSetup.exe.
Follow the installation wizard. By default, Ruskin will be installed to C:\RBR.
At the end of the installation, you will see a prompt asking, "Would you like to install the logger driver at this 
time?"
Click Yes to install the drivers.

.
A shortcut to Ruskin will appear on the desktop and in a Start menu folder.

You may need to run the setup application as an administrator to install the driver correctly.

The most recent version of Ruskin software can be found at https://rbr-global.com/products/software.

https://rbr-global.com/products/software
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3.2 Install Ruskin on a Mac
You can install Ruskin on a Mac running OS X 10.12 (Sierra) or later.

Steps
Connect the USB stick included with your instrument to a port on your adaptor.
Navigate to the "OSX" folder and double-click on the file Ruskin.dmg.
When the disk image window opens, drag the Ruskin icon into the Applications directory and wait for the copy 
to complete. An application named "Ruskin" will appear in the Applications folder.

.
Right-click on the icon, and select Open.
The dialogue box shown below will prompt you to authorise the opening of Ruskin. 
.

.

.

.
Drag the Ruskin.app application to the Dock.

Always use the default Applications folder as the working directory.

You may need to navigate to System Preferences > Security & privacy to allow the apps downloaded 
from “Anywhere” to complete the installation.


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3.3 Update Ruskin
To take advantage of new features and bug fixes, ensure that you are using the most recent version of Ruskin. 

Find the most recent version of Ruskin at https://rbr-global.com/products/software.
Receive an automatic notification about a new release when you start the application.
Check from within Ruskin by navigating to Help > Check for updates. 
Send an email to support@rbr-global.com, subject: "Ruskin update request", and ask us to add you to the 
mailing list. You will receive an email as soon as the new version is released. 

If you have a broadband connection, simply follow the installation instructions on your computer. Otherwise, request a 
USB stick from RBR.  

.

3.4 Uninstall Ruskin
Uninstall Ruskin only if you no longer need to manage RBR instruments from your computer.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation program 
deletes the older files before installing the newer ones. For more information, see Update Ruskin.

Uninstall Ruskin on a PC, Windows 7, 8, 8.1, or 10
Go to Start > Control Panel > Programs.
Under Programs and Features, click Uninstall a program.
Find Ruskin on the list.
Click Ruskin to highlight it.
Click Uninstall.

Uninstall Ruskin on a Mac, OS X 10.12 or later

Move the Ruskin application from Applications to the Trash.

It is not necessary to uninstall the older version of Ruskin before installing the newer version. The installation 
program deletes the older files before installing the newer ones. It does not delete any Ruskin data files or log 
files.



Removing Ruskin will not delete your data files or your diagnostic logs.

https://rbr-global.com/products/software
mailto:support@rbr-global.com?subject=Ruskin%20update%20request
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4 Support
You can get in touch with RBR in several different ways:

Send us an email.  For technical questions, use support@rbr-global.com, and for general inquiries, info@rbr-
global.com.

Contact us via the website at https://rbr-global.com/about-rbr/contact-rbr.

Call us at +1 (613) 599-8900.

Send us a bug report from within Ruskin itself. 

The Help menu on Ruskin offers access to technical documentation, feedback forms, and software updates. 

When experiencing an issue, look for a solution under the Help menu before contacting RBR. 

mailto:support@rbr-global.com
mailto:info@rbr-global.com
https://rbr-global.com/about-rbr/contact-rbr
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4.1 Release notes
Click on Help > Release notes to open the Welcome window. It will outline new features, improvements, and bug fixes 
associated with each release version.

4.2 Documentation
Click on Help > Documentation to open the menu tree. Browse through a variety of guides available for instruments 
and accessories. 

.

4.3 Comment on Ruskin
There is an advantage to sending a bug report from within Ruskin because this allows you to include the diagnostic 
logs, RSK datasets, screenshots, and any other files that could help us reproduce the problem and find the solution as 
quickly as possible. Follow the steps below. 
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Steps
Click on Help > Comment on Ruskin... . The Feedback to RBR form will appear.
Enter your identification information. 
Enter a brief summary of the problem. 
Provide a detailed description (serial number for the instrument, overview of the problem, deployment details, 
initial tests, and, for software bugs, steps to reproduce the issue)
Include any attachments, if required. 
Verify all the information entered and click Submit. 

.

4.4 Check for updates
Click on Help > Check for updates to search for the latest software version. 

.If your software is up-to-date, no further action will be required. 

If an update is found, Ruskin will offer to install it. Follow the prompts. Restart Ruskin for the updates to take effect.



RBR#0006106revJ 16

•
•
•

1.

2.
3.

1.

2.

4.5 Feature codes
Sometimes, RBR may release new features to certain users only, as a beta trial. This includes:

Features in early development  
Features supporting a new product, in preparation for the product launch
Features requested by a specific customer

Usually, the goal is to get feedback and improve the feature before its official release. Contact your sales representative 
or RBR support team at support@rbr-global.com if you have questions about your feature code.

Steps
Click on Help > Feature codes... 
The Feature codes window will appear. 

Enter the feature code provided by RBR.
Click ADD.

If the code is correct, Ruskin will save the feature in the local database and enable it. In most cases, you will have access 
to the new feature immediately, without restarting Ruskin. Otherwise, you will receive any additional instructions at the 
time when you receive the feature code.  

Errors
The feature code is not valid. 
This error may indicate the code was entered incorrectly or it is not compatible with the current version of 
Ruskin.
The feature code is already enabled.
This error may occur when another user has already activated this code. 

mailto:support@rbr-global.com
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5 Quick start - Ruskin Desktop
Ruskin Desktop version is designed for computers and laptops. It generates dataset files which include raw 
measurement data, firmware and software versions, dates and times, sampling settings, power settings, measured and 
derived parameters, errors and events, calibration coefficients, and diagnostic information, offering the fullest Ruskin 
experience. 

5.1 Simulate an instrument
Ruskin can simulate most instruments and sensors that RBR produces. We recommend that you experiment with 
different simulated options before enabling a schedule for your actual deployment. This practice will also help you 
become more familiar with how an RBR instrument interacts with Ruskin and how to configure its settings and 
features. Work with simulated instruments the same way as you work with a real RBR instrument, configuring, 
calibrating, and fetching data.

.

Steps
From the Instruments menu, click Simulate an instrument. 

The Configure simulated instrument dialog box will appear.

Currently, simulated instruments cannot be enabled or downloaded. For more information, see Deploy your 
instrument.


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2.

3.

Click your instrument family and make your selections.

Click OK to proceed.
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4.

5.

Your instrument will appear under Instruments in the Navigator view. Simulated instruments will have a prefix 
"sim" in the front of their name.

The instrument properties will be displayed on the right, under four tabs.

.
The Configuration tab displays status, clock, sampling mode and speed, power options, and deployment 
estimates based on these parameters
The Information tab includes general details, such as the instrument model, generation, serial number, 
firmware version, power source, battery status, and the channels
The Calibration tab allows access to the current calibrations for each channel in the instrument
The Parameters tab outlines default values used by the sensor when performing computations and 
derivations

Familiarise yourself with the instrument by changing configuration options and comparing deployment 
estimates. Select the desired configuration using the dropdown options or entering the values manually in the 
fields provided.  For simulated instruments, the Plot window will remain empty unless you click the Fetch
button . 

Manage multiple instruments by switching between them in the Navigator window. 
.

To remove a simulated instrument from Ruskin, right-click it in the Navigator window, and select Disconnect 
from instrument. You can also use the Instruments menu.
 Alternatively, simply close its Plot tab by clicking the X. The instrument will disappear from the list.


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5.2 Deploy your instrument
Before using your RBR instruments, you may want to experiment with different options by simulating your instrument
on Ruskin.

When you are ready to use your physical RBR instrument, follow the steps below to ensure that you measure exactly 
what you want on the first attempt. 

Steps
Start Ruskin.

Open the instrument and remove the housing.  
See "Opening and closing a compact instrument" section in the RBR Compact Instrument Guide for more 
details. The Guide is available on Ruskin under Help > Documentation. 

Locate a USB-C port inside of the instrument.

Plug one end of the USB cable (USB-C to USB-C, provided with your instrument) into this port and the other, in 
the USB port on your computer.
The instrument will appear in the Navigator view after a few seconds. The properties for the instrument will be 
displayed in the Properties window, grouped under four tabs: Configuration, Information, Calibration, and 
Parameters.

If you are using the instrument for the first time, you can use either the default preferences or specify your own. 
For more information, see Preferences. You can change them at any time.

Click the instrument you want to use. Verify that it contains the expected sensors under the Information tab. 

Click the Calibration tab to view or modify calibration coefficients.

Click the Configuration tab and go to the Sampling section to select the mode and speed of measurements.  

.

Click the Enable button at the bottom of the Configuration tab to take samples according to the schedule that 
you specified. 
Your deployment will continue until the battery runs out, the memory is full, or you stop your schedule 
manually. 

Ruskin will allow a deployment to run until the instrument can no longer sample. This could be due to a 
full memory or due to power supplies being exhausted.  It will display the estimated battery usage and 
storage capacity based on the parameters you enter. The green widget next to End will indicate the 
number of days your instrument would be sampling, along with the icon representing the limiting 
factor, battery or memory.
Carefully consider this information before you enable a deployment schedule. For more information, 
see Schedule.


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When your deployment stops, click the Download... button at the bottom of the Configuration tab to transfer 
all the sampled data from the instrument to your computer. 
For more information, see Download. 
As soon as you download a new dataset, it will appear in the Navigator window. Refer to Datasets for details on 
managing and analysing your data.

.

.

5.3 Recover your instrument and download data
When deployment is complete, recover your instrument and follow these steps to download your data.

.

Steps
Start Ruskin.

Carefully open the instrument and remove the housing.  
See "Opening and closing a compact instrument" section in the RBR Compact Instrument Guide for more 
details. The Guide is available on Ruskin under Help > Documentation. 

Locate a USB-C port inside of the instrument.

Plug one end of the USB cable (USB-C to USB-C, provided with your instrument) into this port and the other, in 
the USB port on your computer.

The instrument will appear in the Navigator view after a few seconds.

Navigate to the Configuration tab and click Download... . 
See Download for details.

Save the file to your local drive. 
See Preferences on steps to set up your default location. 

Evaluate your data. See Analysis for details.

.

To restore a closed connection to an instrument on Ruskin, click Instruments in the Navigator
window. A list of all instruments physically connected to your computer will appear in the Properties
window.
Find your instrument and deselect its checkbox, and then select it again. Your instrument will re-appear 
in the Navigator window.



Flooded instruments may be under pressure and opening them may be dangerous. Take precautions when 
opening an instrument after deployment.


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Disconnect from your instrument

To disconnect an instrument from Ruskin, right-click it in the Navigator window, and select Disconnect 
from instrument. You can also use the Instruments menu.

 Alternatively, simply close its Plot tab by clicking the X. The instrument will disappear from the list. Please note that 
you will be able to reconnect to it at any time because Ruskin remembers the port of a plugged instrument.

Reconnect to your instrument

To restore a closed connection to an instrument on Ruskin, click Instruments in the Navigator window. A list of all 
instruments physically connected to your computer will appear in the Properties window.

Find your instrument and deselect its checkbox, then reselect it again. Your instrument will re-appear in the Navigator
window.

Remove your instrument

To completely remove your instrument from Ruskin, unplug it from your computer. 

Alternatively, deselect the checkbox next to your instrument, and Ruskin will disable transport to its port. 
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6 Configuration
Use the Configuration tab to set up your deployment parameters. 

After setting up a desired schedule, click Enable.  New values will replace all previously stored schedule parameters. To 
return to previous settings, click Revert settings.

To apply the same schedule to multiple instruments, set up the first instrument and click Enable.  Connect all other 
instruments to Ruskin and click Use auto-deploy settings. Now all instrument will run on the same schedule, including 
logging times, power options, and sampling parameters. To return to previous settings, click Revert settings.

.

6.1 Update firmware
Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised. 

If a newer version is available and this update is critical, the Update firmware button and a warning message will 
appear at the top of the Configuration tab. 

See Critical firmware updates for details. 

To change a schedule already enabled, stop the instrument. If the data acquired up to this point and stored on 
the instrument has value, download it to a file and save at your preferred location. After that, make your 
changes and click Enable.


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6.2 Schedule
The Schedule section includes four fields: Status, Clock, Start, and End. 

Status

The Status field displays the current state of your instrument.

Status Description

Not enabled A deployment has not been enabled.

Configuring instrument Ruskin is writing the deployment configuration to the instrument.

Schedule enabled A deployment has been enabled, but the start time has not yet been reached.

Paused A deployment has been enabled, but a gating condition has not been met.

Logging in progress A deployment has been enabled and the instrument is currently obtaining 
samples and recording them to memory.

Logging, memory full A deployment has been enabled and the instrument is currently obtaining 
samples, but they are not being recorded to memory as there is no available 
space. Data continues to be transmitted over the chosen realtime link.

Stopped, schedule complete A deployment has reached the end time and so has been stopped.

Stopped, memory full The memory has been completely filled with samples and so logging has been 
stopped.

Stopped, user request An enabled deployment has been stoped by user intervention.

Failed An internal error has occurred during a deployment.

Battery failed An internal error with regarding the batteries has occurred.

Clock

When you start a deployment, you can automatically set the instrument time from your computer. Select UTC or Local 
 time, depending on your preferences. 
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Start

Specify the Start date using the dropdown calendar, and the Start time using the up and down arrows. Alternatively, 
check Now to start logging as soon as the Enable button is clicked. 

End

The End date is calculated by Ruskin autonomy engine and indicates when your deployment is likely to stop. This is 
based on sampling schedule, mode, and power selections . Ruskin autonomy engine provides feedback on which 
parameter (power or memory) will be exhausted first. 

.

The parameter in the green bar is the true deployment estimate. In the example shown, your deployment will last 115 
days, until the battery is exhausted. 

.

The parameter in the orange bar indicates how much longer the deployment could last if the preceding parameter 
were not a factor. In the example shown, if your instrument were still powered after 115 days, it could continue logging 
for 496 days more, until the memory becomes full. 

.

...

Ruskin autonomy engine

Ruskin autonomy engine relies on several parameters to estimate the deployment end date: sampling rate, power 
options, and memory. One of the key factors is battery life.  

Battery life prediction is a complicated issue. In RBR instruments, it is a strong function of the type of instrument, type 
and number of sensors attached, sampling mode (sampling rate, gating conditions, realtime data collection), and water 
temperature during the deployment. Manufacturer's data for the batteries may not reflect the way batteries are used in 
RBR instruments, and thus, are not always informative.

Autonomy figures depend on the power draw of the instrument, as well as the derated capacity of the battery pack. 
Batteries are derated to 4°C. These values differ for different battery chemistries. For the most accurate deployment 
estimates, select the same batteries from the dropdown menu as installed in your instrument. 

Ruskin calculates the expected battery usage for the instrument during setup . The nominal capacity of each type of 
battery is described  in the Power section and is given in mAh at room temperature. Battery voltage does not decrease 
linearly and is therefore not an accurate indicator of battery capacity.

To manually edit the originally set date and time values, select and then clear the Now checkbox.

Deployment estimates on Ruskin assume new batteries. Your real deployment times may be shorter if the 
batteries are not fully charged.  



If the End logging date is power dependent and you know that the instrument will be operating under very 
cold conditions, you may want to lower the demands on the battery by lengthening your sampling period or 
opting for different battery chemistry.


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RBR tested batteries of various brands at 6°C; all of them were able to provide the threshold capacity defined in the 
Power section. View these predictions and further de-rate the batteries if the expected deployment is in cold water. 

The software will warn you if the expected battery usage for a particular deployment scenario is approaching the 
theoretical potential mAh.

The software will not prevent your instrument from being started even if a warning is given. However, adjusting 
deployment parameters or replacing the batteries may help extend deployment times. 

.

.

6.3 Power
The Power section includes battery chemistry options and information on sampling power.  Ruskin autonomy engine 
uses these parameters to estimate deployment life.

Battery

The Battery dropdown menu shows available chemistry options for internal batteries. The list depends on your 
instrument. 

Replace batteries before each deployment to maximise the operational time and prevent data loss.

Mixing batteries of different chemistries, brands, and age will reduce performance and potentially damage the 
instrument. Improperly matched batteries may become overheated, leak, or even explode.


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AA-type batteries

RBR instruments can use most chemistries of AA batteries.

Name Chemistry Model Voltage (V) mAh*

Lithium thionyl chloride Li-SOCL 2 Tadiran TL-4903S 3.7 2400

Lithium iron Li-FeS2 Energizer L91AA 1.5 3500

Alkaline Zn-MnO2 Rayovac AL-AA 1.5 2500

Li-ion Li-NiMnCo BatterySpace LC14500 3.6 750

Nickel metal hydride Ni-MH Duracell DX1500B4N 1.2 2400

*The nominal capacity of each type of battery is given at room temperature.

.

Ruskin estimates autonomy figures based on the power draw of the instrument, as well as the derated capacity of the 
battery pack. Batteries are derated to 4°C . These values differ for different chemistries (see above). For the most 
accurate deployment estimates, select the same batteries from the dropdown menu as installed in your instrument. 
Alternatively, use Ruskin to simulate your instrument with different batteries and find which chemistry works best for 
your deployment.

Replace batteries before each deployment to maximise the operational time and prevent data loss.

Sample power details

Click on the arrow to open the information drawer with sample power details, such as energy per sample, sample 
duration (if applicable), and sleep power. 

Lithium thionyl chloride batteries are only recommended for T, D, T.D, and C.T.D instruments. Sensors with 
high inrush current will not work correctly on this type of battery.


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6.4 Sampling
The Sampling section includes three fields: Mode, Speed, and Rate, as well as several optional fields available with 
certain sampling modes. 

Mode

Depending on your instrument, different dropdown options may be available. See Tide and Wave for information on 
how to configure these modes. 

RBRsolo3 T  | fast8 : RBR solo3 D  | tide: RBR duet3 T.D  | wave:

Speed and Rate

These are the only two parameters you need to configure Continuous sampling mode.

Check Speed to select the sampling Rate in Hz from the dropdown menu. The default option is always the highest 
instrument rating; for example,  | fast16 will default to 16Hz. 

.

Uncheck Speed to enter the sampling Rate manually in hours, minutes, and seconds (HH:mm:ss format). The fastest 
rate to enter manually is 1s. Type the numbers in, or use the up and down arrows.

All  | tide and  | wave instruments can sample at rates of  2, 4, 8, or 16Hz.
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6.4.1 Tide
Tide sampling mode is similar to Average, as the instrument will also collect data at a certain rate, and then average 
those samples to produce a single value to store on the instrument. However, when set to Tide, the instrument uses 
averaging to remove wave noise data from pressure measurements.

.

In addition to Speed and Rate, there are two more parameters required for Tide mode: Duration and Interval. 

Duration specifies the time range over which to average. It must always be longer than Speed. 

Interval is the repetition period for performing the averaging. It must always be longer than Duration.

There are two versions of sampling controls for Tide sampling mode: simple and advanced.  Make your selections in 
Preferences.

Simple sampling controls

When using the simple version, select Speed, Duration, and Interval from pre-defined options in three dropdown 
menus.  

In the example shown, the sampling rate selected is 16Hz (16 samples per second). The instrument will be logging for a 
duration of one second, then pause and average the sixteen samples collected. After an interval of five minutes, it will 
start logging again, repeating the same cycle. 

Only instruments with the | tide16 feature support Tide sampling mode. 
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•

Advanced sampling controls

When using the advanced version, select two or all three parameters manually. 

All parameters are the same as in the previous example. 

6.4.2 Wave
Wave sampling mode is similar to Burst, as the instrument will also collect a specified number of samples at a specified 
rate, and repeat this operation at a specified interval. When in Wave mode, the instrument takes multiple pressure 
readings in a burst and reconstructs the surface wave time series. This mode records both tide and wave information. 

Speed or Rate are parameters defining individual pressure readings. 
The highest possible frequency visible in the data is limited to ½ the sampling rate. However, this mathematical 
limit cannot be achieved because of wave attenuation, and real data are actually lower. 
The sampling rate defines the resolution of the frequency spectrum which can be calculated from the wave 
data. 
The sampling rate, together with the burst duration, defines the lowest frequency which can be assessed in a 
wave burst.

In addition to Speed and Rate, there are two more parameters required for Wave mode: Duration and Interval. 

Duration specifies the number of samples to record.

Interval is the repetition period for performing the burst. It must always be longer than the time it takes to obtain 
the number of samples indicated in Duration.

Additionally, you may enter Instrument altitude and Mean depth of water to estimate possible wave periods for your 
deployment. These parameters are not mandatory for the instrument to work, but allow you to get an idea of what to 
expect.

At every Interval, the instrument records only one sample, averaged over all samples collected during the 
period of Duration. The rest of the samples are discarded after averaging is performed. 



Only instruments with the | wave16 feature support Wave sampling mode. 

Consider unique aspects of deployment environment when setting up Wave sampling mode.
For example, while a 30-minute interval tends to work in most cases, shorter intervals may suit better when 
encountering ocean swells which have longer wavelengths than noise but shorter than tide. 


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Instrument altitude is the actual height of the instrument in metres above the seabed. This is defined by 
deployment requirements, and the instrument must be physically affixed at this height during the installation.

This parameter is stored on the instrument and used to compute wave statistics for pre-deployment 
analysis.

Mean depth of water is an estimate of the average water depth in metres, used for the initial prediction of wave 
frequency. It must always be greater than Instrument altitude. 

This parameter is not stored in the logger and only used to compute wave statistics. It is adjusted post-
deployment through the RSK file.
Ruskin will calculate the actual mean depth of water from the instrument altitude and its depth 
measured during the deployment. 

There are two versions of sampling controls for Wave sampling mode: simple and advanced. Make your selections in 
Preferences.

Simple sampling controls

When using the simple version, select Speed, Duration, and Interval from pre-defined options in three dropdown 
menus.

A common configuration is 4Hz sampling for 4096 samples every 30 minutes.  

Enter Instrument altitude and Mean depth of water manually. Estimates for wave statistics will be immediately 
displayed: maximum wave frequency and minimum wave period (essentially, they reflect the same concept because 
period = 1/frequency). These values can be adjusted post-deployment through the RSK file.
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.Advanced sampling controls

When using the advanced version, enter all or some parameters manually.

This option allows more flexibility with your values. For example, with a rate of 4Hz and a duration of 4096 samples, the 
instrument will be sampling 17 minutes 4 seconds. You can set up near continuous sampling by setting the interval to 
17:05. Logging will be on every second except the one remaining second of the interval, and then start again. 

.

.

Deployment depth of | wave16 instruments

Attach your  | wave16 instrument to a suitable support below the surface of the water, such as a dock or other rigid 
mooring, to completely immobilise it.  

Enter the expected mean depth of water and the known instrument altitude (height above the seabed). From these 
values, Ruskin will estimate wave frequencies and wave periods that your instrument could measure (period = 1/
frequency). On data retrieval, Ruskin will calculate the actual mean depth of water from the instrument altitude entered 
and its depth measured using the pressure transducer, and then use this actual depth for computing all wave statistics 
during deployment. 

The physics of what a pressure transducer can measure depends on the height of water above as well as the depth of 
water below it. High frequencies attenuate very quickly with depth. The depth of the deployment is critical in 
determining frequencies/periods of the wave data the instrument will be able to capture. It is the depth, not orientation 
of the pressure transducer that affects these measurements.

The timestamp of the burst for both Tide and Wave datasets is the beginning of the burst.

The basic rule is to place the instrument as close to the surface as possible without it emerging from the water 
due to large waves or low tides.





RBR#0006106revJ 33

Instrument fixed to a dock below the water surface

Wave attenuation as a function of depth for various wave periods
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6.5 Ranging sensors
The Ranging sensors section has two dropdown menus, Sensor and Range. 

The former displays the name and index of the channel, which for the RBRcoda3 Tu is always Turbidity (1). The latter 
specifies the gain level used for the deployment. The units of measurement are NTU (Nephelometric Turbidity Units). 

Set Range to Auto to enable auto-ranging setting. Your instrument will change the gain setting on the front-end 
amplifiers to the range most appropriate for its environment. 

.

To display the range change events, select Diagnostic from the dropdown under the Events button  in the Plot
window toolbar.

.

Range change events are displayed as "RANGE XX Units" where XX indicates the current range and units are the units of 
measurement, for example: RANGE 500 NTU. For  | fast sampling, where the change may be occurring over a number of 
samples, the label will read, "RANGE CHG", followed by the final range change event.

.

Alternatively, select a fixed gain setting to maintain the same setting throughout your deployment. 
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1.

2.

3.

6.6 Download
The Download... button is located next to the Memory used bar, at the bottom of the Configuration tab.  

You can download data from your instrument at any time. However, it is especially important to do so when you stop a 
schedule. All the data on the instrument will be erased as soon as you enable a new deployment.

Steps
Click the Download... button. 
A dialog box will appear.

Enter a name for the data file in the Save As field, or accept the default name. 
By default, the RSK file name uses the Ruskin file naming convention (see RSK files). 

Select the download location from the Where dropdown menu, or accept the default location. 
.

RBR recommends storing your data on a local drive rather than a network storage drive. Cloud storage 
options such as GoogleDrive and Dropbox may extend download times.


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4.
.
The new dataset will appear automatically in Navigator window under Datasets. 

The Properties view will change to the new dataset, with the following tabs: Analysis, Overview, Channels, and
File info. 
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5.

6.

All the data stored on the instrument at the time of the download will be automatically plotted in the Plot
window.

When you download data again while on the same schedule, the RSK file will pick the same data and append it 
with any new data stored since the last download.

Go to the Overview tab to add a comment for the download. Enter your message and click Save comment.  
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6.7 Use auto-deploy settings
When working with a large number of similar instruments, Ruskin offers various automatic tasks, which can be set up 
from the Instruments menu on the top toolbar.

This feature may be convenient when you need to deploy several instruments with the same sampling capabilities. 
Select an instrument to use as the model and configure it. This will be your model schedule. Verify that these settings 
meet your requirements and all values are entered correctly. 

When you connect to an instrument with same sampling capabilities as the model instrument, Ruskin will configure it 
to match the the model schedule. 

If your were connected to an instrument before setting up your model schedule, you can click Use auto-deploy 
settings to apply them to that previously connected instrument. 

Click Revert settings when you wish to return to a previously configured schedule. 

Enable each instrument individually to start deployments. 

To confirm which auto-deploy parameters are set on Ruskin, go to Instruments > View auto-deploy 
settings... . The Auto-deploy settings box will open, with saved parameters outlined. 



You cannot use Revert settings after clicking Enable.  To change a schedule already enabled, stop the 
instrument, restore old values manually, and click Enable again. 


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•
•

6.8 Enable / Stop
Ensure that your instrument is ready to be deployed before enabling a schedule. See Deploy your instrument. 

To allow the instrument to start logging, click Enable. This button is at the bottom left of the Configuration tab.  

The Enable button will now read Stop. The status will become "Schedule enabled" or "Logging in progress", depending 
on the configuration. 

Logging will start when one of the following occurs:
The Now button is checked
The Start time arrives
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If you  click Enable, and the instrument memory is not empty, you will see a warning.

Before proceeding, download the data from your instrument (see Download). If you are sure that the information is 
saved or not needed, click Erase and enable logging.

To manually stop the instrument, click Stop.

Logging will stop on its own when one of the following occurs:

The End logging time is reached
The power source is removed or depleted
The memory is filled

All editable fields become greyed out after you enable a schedule. 
To change any deployment parameters, stop your instrument, adjust the settings, and start a new 
deployment.


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7 Information
Use the Information tab to view general information for each of your instruments, such as as model, generation, serial 
number, firmware version, power source, and the channels. 

In the Instrument details section, find the model, generation, and serial number for your instrument, as well as the 
firmware version installed and link used. 

.

Refer to the Power section for the power source, power type, and voltage. 

.

Under Channels, confirm measured and derived parameters for your instrument. 
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8 Calibration
The Calibration tab displays calibration coefficients for each parameter, and the date and time of the last calibration.

Select a sensor from the Parameter dropdown menu to display its calibrations.

RBR calibration certificates contain calibration equations, coefficients, and residuals for each sensor. 

RBR recommends calibrating your instrument before any critical deployment, periodically once a year, or if you suspect 
the readings to be out of specifications.

Discuss your calibration requirements with RBR. In some cases, the instrument may need to be returned to RBR to have 
it checked and re-calibrated.

To contact RBR for our current calibration fees, click Request calibration quote. A Request for quote dialog box will 
appear.

mailto:support@rbr-global.com
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Verify that all information is correct and click Submit.

Simple calibration controls

When using the simple version, you will be able to view and edit only the main calibration coefficients, displayed as "C" 
values: C0, C1, C2, C3. 
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Advanced calibration controls

When advanced calibration controls are enabled in Preferences , you will be able to view and edit both main and 
dependent coefficients. Dependent coefficients are displayed as "X" values: X0, X1, X2, etc. 

You can edit the coefficients. As soon as you make a change and move to another cell, a new calibration date will be 
displayed. Also, Store calibration and Revert calibration buttons will become active. 

Use Store calibration to save the new values.

Use Revert calibration to recover to the original coefficients if you have not already saved your changes to the 
instrument. 

Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will be lost 
once your session is closed. 



You cannot use Revert calibration after clicking Store calibration. Once the coefficients are saved to the 
instrument, you will need to restore old values manually and save them again. 


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9 Parameters
The Parameters tab displays all the parameters the RBR instrument may need for calculating derived channels.

If your instrument can measure a parameter, it will use the measured value. Otherwise, you can enter the necessary 
values manually, and they will take effect immediately. 

For example, you always need atmospheric pressure and density for derivation of depth. Default values in Ruskin 
correspond to sea level and sea water. Therefore, it is especially important to adjust these parameters when working at 
high altitudes in fresh water. 
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10 Preferences
On your Mac, access Preferences from the Ruskin dropdown menu in the top toolbar.

On your Windows PC, use the Options dropdown menu to set up your preferences. 

Factory-set global defaults require no changes in most situations. However, as you learn more about what Ruskin can 
do, you may want to change some of these settings to better suit your requirements. The global preferences include:

Derived channels (applies to some legacy instruments)
Facility (authorised users only, requires login)
General (download locations and options, sampling and calibration controls, export options)
Plotting (channel visibility and channel colours)

10.1 Derived channels

.

The Derived Channels section of the Preferences dialog box has four tabs:  Depth, Conductivity - Salinity, Dissolved 
O2, and No sensor values, where you can choose additional channels derived from measured channels. 

Derived channels calculated by the instrument as well as those calculated by Ruskin are automatically added to the 
default channel list in both the live Plot view and the static dataset.

The Derived channels settings are intended for XR(X),1060, 2050, and 1050 RBR legacy data loggers. They do 
not apply to newer generations. They do not apply to any RBRcoda or RBRcoda3 instruments.
Newer generations calculate all possible derived channels for that specific instrument.
Use the Parameters tab in the instrument Properties window to set up initial parameters for calculating 
derived channels.
For downloaded files, use the Parameters tab in the dataset Properties window.


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1.

2.

3.

a.

If your instrument has a pressure channel, you can use its measurements to derive a depth channel. The data calculated 
for this derived channel appear along with measured channels in the Plot view and in datasets.

Select the Enable Depth Channel checkbox.
.

.
In the Atmospheric Pressure box, type the value in dbar or use the default value. This value corrects the 
pressure measurements during the depth calculation.
.

Select either the Simplified calculation or Seawater calculation.
.

.
To use the simplified calculation, type the actual water density, or use the default value. Note that for 
freshwater, the density should be set to 1.0.

For newer generation instruments, all derived channels are calculated regardless of the checkbox 
status.



The default Atmospheric Pressure value is 10.1325. Adjust this value manually to represent a different 
altitude.



Ruskin can calculate depth based on the simplified calculation or the UNESCO seawater calculation. 
The instrument always calculates depth using the simplified calculation. 



Depth
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b.

1.

2.

To use the UNESCO seawater calculation, specify the latitude of the data collection in degrees and 
minutes.

.

.

Dissolved O2

You can derive a dissolved oxygen channel that measures oxygen saturation as a percentage. 

Click the Dissolved O2 tab and select the Enable Dissolved Oxygen Channel checkbox.
.

.
If your instruments use the Oxyguard DO or RINKO DO sensor, select the Derive concentration using the Weiss 
equation checkbox and the output unit: µMol/L, mg/L, or mL/L.
.

The Conductivity - Salinity tab is only relevant for legacy standard instruments with a conductivity sensor. It 
does not apply to legacy compact instruments.



For newer generation instruments, all derived channels are calculated regardless of the checkbox 
status.


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3.

4.

.
If your instruments use the Aanderaa Optode DO sensor to measure oxygen saturation, select the Derive 
concentration using the Weiss equation checkbox and the output unit: mg/L or mL/L.
If any of your instruments use the Aanderaa Optode DO sensor to measure oxygen concentration, select the 
Calculate saturation using the Garcia and Gordon equation checkbox.
.

No sensor values

Enter salinity, pressure, and temperature values used to calculate the derived channels when a sensor is not available.

The Weiss equation requires values for temperature and salinity. If your instrument does not measure 
them, you can specify standard values on the No sensor values tab.



The Garcia and Gordon equation requires values for temperature and salinity. If your instrument does 
not measure them, you can specify standard values on the No sensor values tab.



If you suspect that the derived channel value is incorrect, check to make sure that the No sensor values
entries match the deployment environment.
For example, if a dissolved oxygen saturation measurement is made in a lake at 8ºC but the No sensor values
salinity is 35 and the temperature is 15ºC, concentration reported will be incorrect.
Adjust the No sensor values entries and recompute.


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10.2 General
Use the General preference page to set up file locations, language, download options, sampling and calibration 
controls, and export options. 

You can click Apply to save your changes without closing the dialogue box.
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File location

You can control where RSK files, realtime RSK file, and log files are stored by default. 

Specify these locations before downloading any data by typing in a directory name or by browsing. 

RSK files are the datasets obtained from your instrument. 

Realtime RSK files are generated when a connected instrument is streaming or when you enable fetching mode on the 
instrument.

Log files are generated by Ruskin and help when diagnosing issues. These files are automatically attached to issues 
generated using the Comment on Ruskin feature.

You can change where future files are stored by default at any time. When done, click Apply or Apply and Close.  The 
changes will take effect immediately.

Language selection

Ruskin is available in six languages: English, French, Spanish, Simplified Chinese, Korean, and Japanese.

Select your language from the dropdown menu and click Apply or Apply and Close. Ruskin will need to restart for the 
changes to take effect. 

RBR recommends storing your datasets on a local drive rather than a network storage drive. Cloud storage 
options such as GoogleDrive and Dropbox may extend download times.


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Download options

Select the appropriate checkboxes to change your download preferences.

When done, click Apply or Apply and Close.  The changes will take effect immediately.

Sampling control

 Select the checkbox to enable advanced controls when setting up your sampling options.

With simple controls, you will select Speed, Duration, and Interval from pre-defined options in three dropdown 
menus.  When advanced controls are enabled, you will be able to enter these parameters manually and achieve a more 
precise setting. 

When done, click Apply or Apply and Close.  The changes will take effect immediately.

Calibration control

 Select the checkbox to enable advanced controls when setting up your calibration options. 

With simple controls, you will be able to view and edit only the main coefficients (C). When advanced controls are 
enabled, you will be able to view and edit all main and dependent calibration coefficients (C, X) for any channel.

When done, click Apply or Apply and Close.  The changes will take effect immediately.

The Enable download schedule UI checkbox is only for legacy instruments.
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Export options

Select the checkbox to enable raw data export. Use this option for downloading your RSK file when storage space is 
limited or expensive. The dataset will be exported in the most compact raw binary format. 

When done, click Apply or Apply and Close.  The changes will take effect immediately.

.

.

10.3 Plotting
Adjust default settings for the graphical display in the Plot view. Manage selections in Channel visibility and Channel 
colours, and apply them globally.

Channel visibility

The Channel visibility tab displays many options to hide or show specific information.

Opt for displaying errors and events for a more informative graph, or hide them for a cleaner view. 

Select the By default, hide all measured channels checkbox to display only derived channels.

Select the By default, hide all derived channels checkbox to display only measured channels.

Otherwise, pick and choose channels to display or hide. 

You can click Apply to save your changes without closing the dialogue box.
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When done, click Apply or Apply and Close.  The changes will take effect immediately.

You can override visibility preferences in the Plot view for any particular graphical display.
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Channel colours

The Channel colours tab allows you to choose a different colour for each channel that is shown for information 
currently running in Plot view, or from an opened dataset. Select from the list of pre-defined options or create your own 
colour.

When done, click Apply or Apply and Close.  The changes will take effect immediately.
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11 RSK files
The RSK file is a single file database based on SQLite that allows us to have large files with high-speed access to any part 
of the dataset. They can be read directly in Matlab with our toolkit RSKtools, or exported to Excel, OceanDataView®, or 
text files.

RSK files contain raw measurement data, firmware and software versions, dates and times, sampling settings, power 
settings, measured and derived parameters, errors and events, other diagnostic information. 

For datasets obtained in Desktop mode, the RSK format is full. These files allow changes to calibration 
coefficients. GPS mapping for full RSK files relies on manually added location points.
This file format is available for RBR standard and compact instruments. 
For datasets obtained in Mobile mode, the RSK format is EPdesktop. These files allow charting and GPS 
tracking. They do not allow changes to calibration coefficients. 
This file format is only available for RBR standard instruments. 
For datasets obtained via streaming or fetching, the RSK format is live. Their names contain the "realtime" 
label.  
This file format is available for RBR standard instruments and RBRcoda3 when in streaming mode, and for all 
instruments when fetching. 

To identify the type of the RSK file, go to the File info tab.  

.

File naming convention for datasets obtained during deployments

By default, RSK file names are composed of the following information:
The instrument serial number: six digits
The date of the download (YYYY-MM-DD): eight digits
The time of the download (HH-MM in the 24-hour format): four digits

For example, the file named 209681_20220531_1306.rsk contains the dataset for an instrument with a serial number of 
209681; the data was downloaded on May 31, 2022 at 13:06 (01:06pm), local time. 

The RSK files obtained during a deployment are saved on your  instrument. Download them to your computer before 
starting a new deployment. Go to Preferences to change your default location for RSK downloads.  

.

The file extension is .rsk; it indicates the Ruskin file format and must not be edited. If you change it, your new 
file extension will become part of the dataset name, and the .rsk extension will be appended.



http://rbr-global.com/support/matlab-tools
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12 Datasets
Datasets are RSK files generated by Ruskin and have an .rsk extension. After downloading your datasets, you can view 
and analyse your data using the options below. 

Go to the File dropdown menu to open or close a dataset, export your data, and see the list of available datasets. 

The Datasets context menu in the Navigator windows duplicates some of these options for convenience.

Explore the contents of your datasets in the Properties window.

When a dataset on the list is selected, the Properties window displays four tabs with information related to this 
dataset. Use these tabs to analyse your data, check the calibration certificates, and verify your parameters.
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1.

2.

12.1 Open dataset
Open any stored dataset from the File menu in the top toolbar or from the Datasets menu in the Navigator view. 

Steps
Click File > Open dataset.

Alternatively, right-click Datasets in the Navigator view and select Open dataset. 

A browsing window will appear. Double-click the .rsk file you want to view, or select the file and click Open. 
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3.

4.

The name of the dataset appears and is highlighted automatically in the Navigator view. The Properties view 
changes to the dataset, with four tabs: Analysis, Overview, Channels, and File info.

The data in the file will automatically appear in the Plot view.

To close a dataset, go to File > Close dataset. Alternatively, right-click the dataset name in the Navigator view 
and select Close dataset. 
 Alternatively, simply close its Plot tab by clicking the X. The dataset will disappear from the list.


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1.

2.

3.
4.
5.

12.2 Export
Use the Export option to share your data with others or analyse your data using other software. Datasets can be read 
directly in Matlab with our toolkit RSKtools, or exported to Excel, OceanDataView®, or text files. 

Steps
File menu > Export, then hover to open a set of submenus.

or right-click the dataset in the Navigator window, then hover to open a set of submenus.

Select the appropriate export format (Microsoft Excel, netCDF/netCDF profiles, Text, OceanDataView 
spreadsheet, or Raw binary). 
If exporting annotations, select the category: Full profiles, Downcasts, or Upcasts.
Specify a location and a name for the data file. 
Click Save.

http://rbr-global.com/support/matlab-tools
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12.3 Analysis
Select a dataset in the Navigator view. The Properties view will change to dataset properties, with four tabs: Analysis, 
Overview, Channels, and File Info.

The Analysis tab has two options: Cursor and Calibration.

The Cursor view contains statistical information about deployment, as well as information about the dataset channels 
and their values. 

Move the black cursor ("double lollipop") in the Plot window to display parameter values for each sample selected.

Every time you move the black cursor, going form sample to sample, the table above the plot will display the 
information for this particular sample.
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Select Display statistics checkbox to determine the average value and standard deviation over a range of samples. 
Change the number of samples to average using the up and down arrows.

The table will display the averaging data. The averaging interval will be highlighted in the plot.



RBR#0006106revJ 63

On the Calibration page, you can recalculate your coefficients for the DO and Tu channels. See User calibration.
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12.4 Overview
Use the Overview tab to view general information for each dataset, such as instrument details and deployment events. 

To make a note about this dataset, enter your comment in the field provided and click Save comment.

12.5 Channels
The Channels tab has three options: Information, Calibration, and Parameters. 
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Information

The Information page displays two tables: Measured channels and Derived channels.

Measured channels include measured parameters with their units of measurement, the sensor manufacturer, and the 
range setting (if applicable). 

Derived channels include all available derived parameters with their units of measurement and the methodology used 
to calculate them.

Calibration

The Calibration page displays the calibration coefficients and correction coefficients (as applicable) for each channel, 
as well as the date and time of the last calibration. Select a sensor from the Parameter dropdown menu to display its 
calibrations.

The main calibration coefficients are displayed as "C" values: C0, C1, C2(K). Dependent coefficients are displayed as "X" 
values: X0, X1, X2, etc. 

You can edit any of the coefficients in your dataset, regardless of the advanced calibration controls settings in 
Preferences.
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As soon as you make a change and move to another cell, a new calibration date will be displayed. Also, all three buttons 
at the bottom of the page will become active. 

Use Store and recompute data to recalculate the dataset. Use Revert calibration to recover the previous coefficients 
and data if you have not already selected Store and recompute data.

To revert calibration and recalculation after it was stored, check the Use deployment calibrations checkbox.  Click 
Store and recompute data to save the reverted coefficients.

Parameters

The Parameters tab displays parameters necessary to calculate derived channels and the method used for calculation.

You can edit these parameters to change the derived channel calculation. As soon as you make a change, the 
two buttons at the bottom of the page will become active. 
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Click Update and recompute to recalculate the data and display new values. 

Use Revert settings to recover the previous coefficients and data if you have not already selected Update and 
recompute. 

.

.

12.6 File info
The File info page displays the dataset name and location, Ruskin version used when it was obtained, structure (RSK 
file format), and size.  

For datasets obtained in Desktop mode, the RSK format is full.
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For datasets obtained in Mobile mode, the RSK format is EPdesktop.

For datasets obtained via streaming or fetching, the RSK format is live. Their names contain the "realtime" label. 

Ruskin checks the dataset for compatibility with the newest version of Ruskin software. If the file requires updating, a 
warning message and an Update button will be displayed.

Click Update. It may take several minutes for it to complete. RBR strongly recommends that all datasets are updated 
and meet compatibility requirements.

Failing to update your dataset may result in odd graphical displays and incorrect reporting of the sample 
values.


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13 Plot window
Use the Plot window to view graphical displays of your datasets or live data. When viewing live data, the instrument 
must be attached.  

Each channel appears as a different colour in the plot. These colours are specified under Preferences > Plotting and 
can be changed only there. For information on adjusting your defaults for the Plot window, see Preferences. 

Move the black "double lollipop" cursor from one sample to the next to display parameter values for each sample 
selected. For the datasets, these values will appear in the Properties window above (see Analysis).  For live data, they 
will be on the side of the plot.

The graphical display for each dataset or instrument will be in its own tab.  The dataset file name or the instrument 
model and serial number will appear at the top of the tab. Simulated instruments will have "sim" in front of their name. 

A toolbar at the top right of the Plot window contains various buttons to help you customise, explore, and export the 
graphical display. The buttons selection changes depending on what is displayed in the tab. Hover over a button to 
display its name and function. 

A downsampled representation of the dataset appears in the thumbnail view, along with an indicator of the current 
plotted time range. 
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Position the indicator by clicking on the thumbnail view and dragging the indicator. Resize the indicator by dragging the 
edges left and right. It will zoom the main plot along the time domain to match the new indicator size. 

.

.

13.1 Dataset plot toolbar
Use the plot toolbar to adjust the display of an open dataset. 

The thumbnail view always shows the plot-by-time data, even if the plot is switched to the plot-by-depth 
mode.


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13.1.1 Annotation controls
Annotations are information messages added either by users or by the instrument. 

.

Annotation types

Annotation types are divided in two categories: profiling (Profile, Downcast, or Upcast) or non-profiling (Comment, 
Exclusion, Location, or Calibration). Use annotation controls to manage this information and to navigate the plot. 

Type Function

Profile, Downcast, Upcast Identify profiling

Comment Add a note to your data

Exclusion Remove a non-representative interval from analysis

Location Add in latitude/longitude coordinates for RSK files to track locations of 
data logging

Calibration Calibrate the ODO sensor (available only for RBR standard instruments 
using the RBRcoda3 T.ODO as an integrated sensor)

Open the Filter dropdown menu to select the annotation type to display. The number of annotations for each type will 
be indicated. 

Select an annotation type. The plot will centre on the first item in the selected category. For example, when you select 
Profile, the plot will move to the first profile.
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1.

2.

If you switch the filter to another annotation type within the same category (for example, Profile to Upcast), the plot 
will not change. If you switch to a type from another category (for example, from Profile to Comment), the plot will 
move to the first annotation in the new category (for example, to the first comment). 

Use the Navigation buttons  to navigate between items within the selected category. 

Navigation controls
Move from one annotation to another by clicking the left and right arrows.
Jump all the way to the beginning or end of the list by using the end-left and end-right arrows.
Alternatively, manually enter the number in the Index field to go to that particular annotation. 

Click the Create annotation button  to enter a new comment, location, profile, or exclusion.

Steps to create an annotation
Select the type of annotation to create, for example, Comment.

The cursor in the Plot window will become a two-way arrow   .

Click on the main plot to identify a single point to comment, or click and drag the cursor left or right to select an 
interval. When you release the click, an editable tooltip will open.

The tooltip controls include left and right arrows , Delete , Save , and Close .  

The navigation buttons will be activated if there is more than one item in the selected annotation type. 
Otherwise, the plot will centre on the only item available. 


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5.

•
•
•
•

Enter the necessary information into the fields and save by pressing Enter on your keyboard or by clicking Save 

 on the tooltip. Your new comment will appear in the dropdown list.

Clicking Close  or pressing Esc on the keyboard will close the tooltip without saving. 
.

Click the arrows  on the tooltip to move to the next annotation within the same category. 

Click Delete  on the tooltip to delete the annotation. 
A warning message will appear. 

Click Delete to proceed. This action cannot be undone.

13.1.2 Cast detection
Ruskin automatically enables profile detection on instruments when a deployment is enabled. There are several criteria 
for enabling this feature.

 The instrument must support the castdetection setting
 The instrument must have a pressure sensor
 The deployment must be configured for | fast sampling (2Hz and up)
 The deployment mode must be configured as either continuous or directional

It is possible to recalculate the casts in a dataset using the cast detection feature in the Plot view. 

Click the Cast detection button  to run a cast detection algorithm based on depth and conductivity to 
automatically generate profiles and casts. A warning message will appear.

Edit at least one detail in the tooltip before saving. Otherwise, the annotation will be deleted when 
deselected.  Moving or resizing the annotation counts as editing and saving.


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If you proceed, Ruskin will find peaks, collect events, and overwrite profiles recorded by the instrument. 

.

13.1.3 Event visibility

Click the Event visibility button  to turn on and off the visibility of the various levels of events: Error, Warning, 
Information, and Diagnostic. Its colour will reflect the highest level of event severity reported. 

.

13.1.4 Zoom controls
Default scaling of the plot is based on the minimum and maximum values sampled for each channel.

Use the Zoom in horizontally  and Zoom out horizontally  buttons to increase or decrease the the time 
range displayed. 

In the same way, use the Zoom in vertically  and Zoom out vertically  buttons to increase or decrease the 
resolution of the data displayed. Even more conveniently, hover the cursor and scroll your mouse wheel up and down 
to change the scale. 

Alternatively, hold Shift + left click and drag where you want to zoom in or out.  

This function may be helpful when there are erroneously high or low values that make the real data appear incorrect.
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Hold Ctrl + left click and move your mouse left and right to pan your chart horizontally.

Click a value on the vertical axis and move your mouse up and down to pan your chart vertically to centre as desired. 

Click Reset zoom to maximum bounds  or double-click anywhere on the chart to restore the original 
appearance. 

Use the Toggle auto-ranging button  to turn on and off the auto-ranging of the channel axes. Disabling the auto-
ranging of the axis can be useful for looking at trends in data.
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13.1.5 Export plot

Click the Export plot button  and select file name and location to save the current view of the main plot to a PDF 
or PNG file. The exported file will contain the graph only and retain all the changes to display active at the moment of 
export: zoom, lines and markers, visible events and annotations, and plotting by depth or time.

13.1.6 Appearance controls
Select your data rendering type from the dropdown menu:  Lines, Markers, or Lines and markers.

If no data appears in the Plot view, try changing the rendering to "Display Markers".  Time spans that are larger 
than expected will cause breaks between data points and lines will not be drawn connecting those points, 
whereas markers draw at each individual point.





RBR#0006106revJ 77

Use the Toggle channel visibility button  to open the dropdown menu with the list of available channels and 
options. Check and uncheck channels to display as desired, or select groups to show and hide. 

Select Show raw channels to display measured data with no calibration equations applied. 
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By default, the data are plotted by time. Use the Toggle depth plot  button to switch to the plot-by-depth mode. 

The thumbnail view will continue to display the plot-by-time data. 

.

13.1.7 GPS map

The Show GPS map button  opens a pop-up window with the GPS map for the plot. Click on the map to display all 
the GPS location annotations recorded in the dataset..

.

.GPS mapping for datasets obtained in Desktop mode relies on manually added location points (see Annotation 
controls). All location points you added using the Annotations feature are stored in the dataset file and can be 
displayed in Ruskin via the mapping functionality.

If there is no depth channel, the plot will use the next pressure or pressure-derived channel starting from the 
bottom of the channel list.


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13.2 Live data plot toolbar
You can use the Plot window to view a live graphical display of your instrument sampling. All options described in the 
Dataset plot toolbar section apply to live data display. Additionally, three live data buttons appear at the right end of 
the toolbar: Side data panel, Live plot time range, and Fetch. 

Click the Side data panel button  to toggle on and off the data panel to the right of the plot. It shows the file 
location that will be used to capture samples, the number of samples collected, the values of the last received sample, 
and the currently selected sample.  
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Click the Live plot time range  button to open a dropdown list of time span options.

For example, select 2 minutes to display the data in the thumbnail view and on the side panel by two-minute time 
periods. 

You can also choose to display all of the data collected.

Fetching

Live data can come from one of two sources: streaming or fetching. 

Fetching is the action of asking the instrument to take a reading and report it. 

Click the Fetch button  to start fetching data. The button will change to Pause . 

Click the Pause button  to stop fetching. 
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1.

14 Firmware updates
Ruskin automatically checks if your instrument firmware is up-to-date. Updates may be critical, routine, or customised. 

14.1 Critical firmware updates
If a newer version is available and this update is critical, the Update firmware button and a warning message will 
appear at the top of the Configuration tab. 

Steps
Click Update firmware.
The Update logger firmware window will appear. It will contain Release notes, outlining the new version 
number, its release date, improvements, and bug fixes associated with this release, and two standard buttons at 
the bottom of the window: Close and Proceed. 
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2. Click Proceed to initialise the update.
The instrument will disappear from the Navigator window during the upgrade. Watch the progress bar at the
bottom of the window for the status.

.

If the upgrade does not complete successfully, go to the Instruments menu and launch the update dialogue.

The Update logger firmware window will appear. Click Proceed again to retry. 

If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from 
the USB port and then reconnect to establish communication.

.

.

14.2 Routine firmware updates
If the latest update is not critical, Ruskin will not display any warning message. However, you can always check 
manually if a newer firmware warning is available. Go to Instruments > Update instrument firmware.

The Update logger firmware dialog box will appear. In addition to the new version number, its release date, 
improvements, and bug fixes, there will be two additional sections: Select the instrument to update and Select the 
firmware image. 

Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the 
update process may render the instrument inoperable.


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2.

Steps
From the Instrument dropdown, select the instrument you wish to upgrade.

From the next dropdown, select the latest firmware image.   
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3.
.
Click Proceed to initialise the update.
The instrument will disappear from the Navigator window during the upgrade. Watch the progress bar at the 
bottom of the window for the status.  

.

.

If the upgrade does not complete successfully, click Proceed again to retry. 

If the instrument does not reappear in the Navigator window after a firmware update, disconnect your instrument from 
the USB port and then reconnect to re-establish communication.

.

.

14.3 Manual firmware updates
In certain cases, RBR may supply a customised firmware version, which will not be on the dropdown list. 

Go to the Instruments menu and launch the update dialogue.

The Update logger firmware dialog box will appear.  Follow the steps below to import the firmware image provided by 
RBR and update your firmware. 

Do not disconnect the instrument until a confirmation message is displayed. 
Disconnecting during the update process may render the instrument inoperable.


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2.

3.

4.

Steps
In the Update logger firmware dialog box, click Import.
.

.
Browse to the location of the firmware update file. The file will have the extension .rbrfw.

Select the file and click Open.
The file will appear on the dropdown list. 
.

Click Proceed to initialise the update.
The instrument will disappear from the Navigator window during the upgrade. Watch the progress bar at the 
bottom of the window for the status.  

.

Do not disconnect the instrument until a confirmation message is displayed. Disconnecting during the update 
process may render the instrument inoperable.


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15 Automatic tasks
When working with a large number of similar instruments, Ruskin offers various automatic tasks. 

Access these options from the Instruments menu on the top toolbar.

Alternatively, right-click Instruments in the Navigator window. 

When you enable a task, it will show a checkmark next to it, and the corresponding icon will be displayed in the 
Navigator window. 

Since these tasks can change the state of your instrument, their settings default to "off" each time Ruskin is run.
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3.

Auto-download

When Ruskin detects an instrument, it will automatically start a download process. The downloaded dataset will be 
named following the standard naming convention, and saved in the default directory. Other than possibly creating 
unwanted files, this option is safe since it does not alter the state of the instrument.

.

.

Auto-stop

When Ruskin detects a previously enabled instrument, it will automatically stop the deployment.  If auto-download is 
not selected, it will also display a warning about downloading the instrument data. 

.

.

.

Auto-deploy

When Ruskin detects an instrument, it will stop the deployment and then reprogram your instrument with the last 
known configuration settings. Use this feature when you have several instruments with the same capabilities. 

.

To use this feature, follow these steps:
Connect to an instrument that will act as the model.
Configure this instrument with the desired settings.
Enable Auto-deploy as shown above.

Now, when you connect to an instrument with same capabilities as the model instrument, Ruskin will configure it to 
match the the model schedule. 

.

.

All the data on the instrument will be erased as soon as you enable a new deployment.  RBR recommends 
enabling the Auto-download feature whenever you enable Auto-stop. 



All the data on the instrument will be erased as soon as you enable a new deployment.  RBR recommends 
enabling the Auto-download feature whenever you enable Auto-deploy. 



Auto-deploy implies Auto-stop.
Ruskin must stop your instrument to change deployment parameters, so it will stop even when there is no 
checkmark next to the Auto-stop task. 


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View auto-deploy settings

To view the currently active auto-deploy parameters, go to Instruments > View auto-deploy settings... .

The Auto-deploy settings box will open, with saved parameters outlined. 

.
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16 User calibration

Factory calibration coefficients are calculated for each sensor, and the coefficients are stored on the instrument. 

RBR calibration certificates contain calibration equations, coefficients, and residuals for each sensor. Hard copies are 
provided with each shipment. RBR can replace lost or misplaced calibration certificates upon request. 

RBR recommends calibrating your instrument before any critical deployment, periodically once a year, or if you suspect 
the readings to be out of specifications.

Discuss your calibration requirements with RBR. In some cases, the instrument will need to be returned to RBR to have 
it checked and re-calibrated.

Please contact RBR for our current calibration fees. 

View current calibration coefficients for your sensors under the Calibration tab in the Properties window. 

Sensors such as the dissolved oxygen and turbidity can be field-calibrated.  Update the calibration coefficients for these 
channels periodically. On occasion, you may need to manually enter new coefficients, although this is not 
recommended for factory-calibrated sensors (for example, T or D) unless instructed by RBR.

To calibrate a sensor, you need to let it sample in a known environment and then compare the result to the established 
value.  The difference will be used to generate calibration coefficients. With the N-point method, the known 
environment is changed N times. The higher the N, the more accurate are calibration coefficients. 

.

16.1 Dissolved oxygen sensor calibration
For dissolved oxygen sensors, RBR recommends user calibration using the N-point method, with N = 2, which will 
include a zero reference point and a non-zero reference point. It is, however, acceptable to perform a one-point 
calibration.  

.

16.1.1 Dissolved oxygen data collection
Follow the steps below to obtain the calibration dataset for your dissolved oxygen sensor. 

Equipment and materials
A wide-mouth, black-walled container with a cover
A small container or beaker
Air pump (for example, an aquarium air pump with a stone bubbler) 
Magnetic stirrer
Sodium sulphite Na2SO3
Distilled water

Ruskin configuration
Go to Configuration .
Select UTC or Local, depending on your preferences, to synchronise the instrument clock with your computer.
Set the sampling rate at 1s (1Hz).
Enable your schedule.

mailto:support@rbr-global.com
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Non-zero reference point
Fill the black-walled container with distilled water.
Install the magnetic stirrer.
Install the air pump.
Switch on both the air pump and the magnetic stirrer.
Leave them on overnight, or for at least 3-4 hours, to achieve saturation. 
Submerge the dissolved oxygen sensor in the solution, going in at an angle and stirring to avoid bubble buildup 
on the sensor window. 
Leave some space between the sensor and the beaker walls. 
Position the sensor near the stirrer but not directly in the bubbles. 
The bubbler should be shallower than the sensor.

Record the data for at least 30 minutes.
This is the 100% oxygen concentration calibration point.

.

Zero reference point

In a small container or beaker, prepare a 0.1% solution of sodium sulphite (0.25g of Na2SO3 for 250mL tap 
water). 
Mix the solution thoroughly with a magnetic stirrer. The solution will be oxygen-free after 15 minutes. 
Submerge the dissolved oxygen sensor in the solution, going in at an angle and stirring to avoid bubble buildup 
on the sensor window. 
Leave some space between the sensor and the beaker walls. 

The instrument must be logging throughout the calibration procedure.

Omit this step when performing the one-point calibration. 
If you calibrate your dissolved oxygen sensor using the one-point calibration method at 100% oxygen 
concentration only, calibration should be performed at the expected temperature and salinity of the 
deployment environment.


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Record the data for at least 30 minutes.
This is the 0% oxygen concentration calibration point.

.

.

16.1.2 DO calibration in Analysis tab
For DO sensors, RBR recommends a two-point user calibration, which includes a zero reference point  and a non-zero 
reference point. It is, however, acceptable to use a one-point calibration. 

Two-point calibration steps on Ruskin 
Stop the deployment.

Download the dataset.

Open the dataset on Ruskin. The Properties windows will change to dataset properties, with the Analysis tab 
displayed.
.

.

Click Calibration. 

Select Dissolved O2 saturation  from the dropdown list.

This Na2SO3 solution has a limited lifespan and should not be used for more than a day. 
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6.

7.

By default, the Number of samples  is set to 100, which means Ruskin will average the calibration coefficients 
over a hundred sample points. Typically, this value should be in the range from 50 to 100 samples.
The Raw channel box is unchecked, and thus the true pH values will be displayed in the plot below. To see the 
raw voltage values, check this box. .

.
A downsampled representation of the dataset will appear in the thumbnail view, with two distinct plateaux 
corresponding to 100% and 0%. Irregular readings in-between mark the times when you changed from distilled 
water to sodium sulphite solution and reassembled the setup. 

Click on a stable point in the Plot view corresponding to 100% oxygen. 

The interval of 100 samples will be highlighted. The average value (Avg) and standard error (Std) for this interval 
will appear in the table above. 

Under Real Avg  in the first row, enter 100. 
.
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Repeat the same steps for the second plateau, entering 0 under Real Avg.

Ruskin automatically calculates the calibration coefficients, and the values appear in Calculated coefficients. 
.

Click Copy to save the new calibration coefficients to the clipboard, or write them down.

In the Navigator view, find your instrument.

Click Calibration and select Dissolved O2 saturation  from the dropdown list. 

Click C0 to select the entry field and type in the new value (in this example, -2.6351535 ). 

Click C1  to select the entry field and type in the new value (in this example, 1.0794960 ).

Click Store calibration to save the new coefficients. 

Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will be lost 
once your session is closed. 



https://docs.rbr-global.com/display/RSKDOC/.Calibration+tab+vI
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One-point calibration steps on Ruskin

Stop the deployment.
Download the dataset.
Open the dataset on Ruskin. The Properties windows will change to dataset properties, with the Analysis tab 
displayed.
Click Calibration. 
Select Dissolved O2 saturation from the dropdown list.
Check the 1 point calibration box. 
Click on a stable point in the Plot view corresponding to 100% oxygen. 
The interval of 100 samples will be highlighted. The average value (Avg) and standard error (Std) for this interval 
will appear in the table above. 
Click the RealAvg column and select 100 from the dropdown. 
Click Copy to save the new calibration coefficients to the clipboard, or write them down.
In the Navigator view, find your instrument.
Click Calibration and select Dissolved O2 saturation from the dropdown list. 
Click C0 to select the entry field and type in the new value. 
Click C1 to select the entry field and type in the new value.
Click Store calibration to save the new coefficients. 

.

16.2 Turbidity sensor calibration
RBR compact instruments support turbidity sensors from Seapoint®.

RBR factory-calibrates the turbidity sensors using the N-point method, with N = 7. For user calibration, we recommend 
using the two-point method (N = 2) under fluorescent lighting, which will include a zero reference point and a non-
zero reference point.

Alternatively, you can perform a one-point calibration using a single zero reference point in distilled water. Calibration 
will only correct the coefficients for an offset. 

If you calibrate your dissolved oxygen sensor using the single-point calibration method at 100% oxygen 
concentration only, calibration should be performed at the expected temperature and salinity of the 
deployment environment.



Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will be lost 
once your session is closed. 



When performing the one-point method,  use only a zero reference point.
With a single non-zero reference point, calibration will recompute the slope coefficient.  Go this route only if 
you are confident in your non-zero standard.



https://docs.rbr-global.com/display/RSKDOC/.Calibration+tab+vI
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16.2.1 Tu data collection
Follow the steps below to obtain the calibration dataset for your Tu sensor. 

Equipment and materials
A wide-mouth, black-walled container (large enough to hold the instrument)
Secure black lid for the container with an orifice for the instrument
Small black lid or any light-blocking material to cover the orifice during calibration
400FTU Formazin standard
Distilled water
Large magnetic stirrer
Rubbing alcohol
Soft cloth

Ruskin configuration
Go to Configuration.
Use Local on Ruskin to synchronise the instrument clock with your computer.
Set the sampling rate to 1s (1Hz).
Under Ranging sensors, set Range to Auto. 
Enable your schedule.

Sensor preparation
Wash the sensor and container with distilled water and dry them with a soft cloth.
Check the turbidity window for stains and scratches. 

.
Wipe the  turbidity window with alcohol to remove all stains.  

Zero reference point

The instrument must be logging throughout the calibration procedure.

Do not proceed with calibration if there are serious scratches.
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Fill the black-walled container with distilled water.
Turn on the magnetic stirrer and adjust the RPM to ensure no vortex appears. 
Place the black lid on the container and avoid direct light on the container.
Submerge the sensor though the orifice in the lid, vertically along the wall,  with the turbidity window facing the 
larger water volume. 

.
Cover the orifice with the smaller black lid or light-blocking material, like a thick plastic bag. 
Record the data in distilled water for at least 15min, up to an hour. 
This is the zero-turbidity calibration point.

Non-zero reference point
Repeat the steps for the zero reference point, replacing distilled water with 400FTU Formazin standard.

This is the 400NTU calibration point.

As each reference point takes 15 minutes to an hour, the entire procedure may take up to two hours. 

After completing the procedure for both reference points (or for a single reference point, if using the one-point method), 
proceed to calibration on Ruskin. 

16.2.2 Tu calibration in Analysis tab
For turbidity calibration, we recommend using the two-point method, which includes a zero reference point and a 
non-zero reference point.

Alternatively, you can perform a one-point calibration using a single zero reference point. 

Two-point calibration steps on Ruskin
Stop the deployment.
Download the dataset.
Open the dataset on Ruskin. The Properties windows will change to dataset properties, with the Analysis tab 
displayed.

The distance from the turbidity window to the container wall must be at least 20 cm. 
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Click Calibration. 

Select Turbidity from the dropdown list.
By default, the Number of samples is set to 100, which means Ruskin will average the calibration coefficients 
over a hundred sample points. Typically, this value should be in the range from 50 to 100 samples.
The Raw channel box is unchecked, and thus the true turbidity values will be displayed in the plot below. To see 
the raw voltage values, check this box. 

A downsampled representation of the dataset will appear in the thumbnail view, with two distinct plateaux 
corresponding to 0NTU and 400NTU. Irregular readings in-between mark the times when you changed from 
water to formazin and reassembled the setup. 

Check the box next to the first row in the calibration table. 

Click on a stable point in the Plot view corresponding to zero NTU. 

The interval of 100 samples will be highlighted. The average value (Avg) and standard error (Std) for this interval 
will appear in the table above. 
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Under Real Avg in the first row, enter 0 and press enter. 

Repeat the same steps for the second plateau, entering 400 under Real Avg.
Ruskin automatically calculates the calibration coefficients, and the values appear in Calculated coefficients. 

..

.
Click Copy to save the new calibration coefficients to the clipboard, or write them down.
In the Navigator view, find your instrument.
Click Calibration and select Turbidity from the dropdown list. 
Click C0 to select the entry field and type in the new value (in this example, 3492.6945 ). 
Click C1 to select the entry field and type in the new value (in this example, -4767.0838).
Click Store calibration to save the new coefficients. 

When a two-point calibration is performed correctly, residuals will be 0. 

Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will 
be lost once your session is closed. 


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One-point calibration steps on Ruskin

Stop the deployment.
Download the dataset.
Open the dataset on Ruskin. The Properties windows will change to dataset properties, with the Analysis tab 
displayed.
Click Calibration. 
Select Turbidity from the dropdown list.
Check the 1 point calibration box. 
Click on a stable point in the Plot view corresponding to 0NSU. 
The interval of 100 samples will be highlighted. The average value (Avg) and standard error (Std) for this interval 
will appear in the table above. 
Click the RealAvg column and select 0 from the dropdown. 

Click Copy to save the new calibration coefficients to the clipboard, or write them down.
In the Navigator  view, find your instrument.
Click Calibration  and select Turbidity from the dropdown list. 
Click C0 to select the entry field and type in the new value. 
Click C1 to select the entry field and type in the new value.
Click Store calibration to save the new coefficients. 

Always click Store calibration to save new coefficients on the instrument. Otherwise, all changes will be lost 
once your session is closed. 



https://docs.rbr-global.com/display/RSKDOC/.Calibration+tab+vI
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17 Revision history
Revision No. Release Date Notes

1.0 01-Sep-2012 Original

2.0 01-Oct-2014 Adding RBRsolo D and DO and RBRduet support

B 12-Sept-2017 Final revision for compact loggers

D 12-Dec-2018 Updated installation details, screenshots, added auto-deploy features

E 13-Mar-2019 Updated plotting information, firmware upgrades, and screenshots

F 06-Jun-2019 Updated introduction, and screenshots

G 04-May-2020 Updated screenshots, RBRcoda T.ODO customer calibration, and removal 
of Logger hardware

H 18-Aug-2020 Updated firmware upgrade procedure, added annotation collapsing/
expanding, and GPS plotting

J 31-Aug-2022 Restructured the user guide to reflect Ruskin interface, added a dedicated 
page for RSK files, edited existing instructions for clarity, removed 
outdated sections and screenshots
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